PKG_CONX

The PKG_CONX is similar to install_conflict_packages key in INFO file, but it additionally defines the restriction according to specific DSM versions.

priority of PKG_CONX is higher than install_conflict_packages in INFO

Each configuration file is defined in standard .ini file format with key/value pairs and sections. A section describes a unique name of dependent/conflicting package. Each section contains information about the requirements of package versions and the restriction of DSM versions.

Key Description Value
pkg_min_ver Minimum version of conflicting package. Package Version
pkg_max_ver Maximum version of conflicting package. Package Version
dsm_min_ver Minimum requried DSM version. X.Y-Z
DSM major number, DSM minor number, DSM build number
dsm_max_ver Maximum requried DSM version. X.Y-Z
DSM major number, DSM minor number, DSM build number
; Your package conflicts with Package A in any version
[Package A]

; Your package conflicts with Package B version 2 or newer
[Package B]
pkg_min_ver=2

; Your package conflicts with Package C version 2 or older
[Package C]
pkg_max_ver=2

; Your package conflicts with Package D version 2 or newer, but it will be ignored when DSM version is smaller than 4.1-2668
[Package D]
dsm_min_ver=4.1-2668
pkg_min_ver=2

; Your package conflict on Package E with version 2 or newer but it will be ignored when DSM version is bigger than 4.1-2668
[Package E]
dsm_max_ver=4.1-2668
pkg_min_ver=2

results matching ""

    No results matching ""